Atlassian Connector for Eclipse – Installation issues

I’ve been having a problem installing the Atlassian Connector for Eclipse (which gives integration to a bunch of Atlassian and non-Atlassian tools – mostly I’m after Fisheye and JIRA). The installation constantly failed for me on this error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Atlassian Connector for Eclipse (recommended) 1.1.0.v20090624 (com.atlassian.connector.eclipse.feature.group 1.1.0.v20090624)
Missing requirement: Atlassian Connector for Eclipse (recommended) 1.1.0.v20090624 (com.atlassian.connector.eclipse.feature.group 1.1.0.v20090624) requires ‘org.eclipse.mylyn.jira_feature.feature.group [3.2.0.I20090529,3.3.0)’ but it could not be found

Today I found this issue in Atlassian’s issue system: [#PLE-393] Installation error – Atlassian Projects. What it comes down to is that one of the update sites shipped with Eclipse is disabled in some of the distros (the JavaEE one, in my case).

The issue has the instructions, but for anyone too lazy to follow the link:

The problem seems to be that the Mylyn update sites (which has JIRA) is not enabled in your copies of Eclipse. There is a bug in Eclipse that these sites may not be automatically enabled even though we specify that we require them for installation. To enable this site:

1. open Help > Software Updates…
2. switch to the “Available Software” tab
3. click on “Manage Sites…”
4. look for either the Mylyn Extras update site or a url that looks like: http://download.eclipse.org/tools/mylyn/update/extras and check make sure that it is checked
5. look for either the Mylyn For Eclipse 3.4 update site or a url that looks like: http://download.eclipse.org/tools/mylyn/update/e3.4 and make sure that it is checked
6. try to install the Atlassian Eclipse Connector again

And with that, I get my JIRA integraton to Mylyn working again! Joy and happiness abounds.